Page 1 of 2

Thecus NASs: N2200EVO, N4100Pro, and managing DOMs

Posted: Thu May 09, 2013 2:29 pm
by asavage
I've got a NAS4Free PC-based NAS that I use primarily for backups, but it has issues.

Lewis has loaned me a brand-new Thecus N2200EVO to evaluate. It comes bare, w/o drives.

It's always disappointing to have a box arrive accordianed.

(click on any image for larger)

Image Image Image

However, Lewis did a good job of padding the OEM box inside, and there's no visible damage.

I found a spare 10-year-old 40G SATA drive, and bolted it to one of the HDD carriers.

Image Image

But, the damned thing will not slide in the chassis.

The plastic doors just snap on to hinge posts, so I removed one to see what is going on.

The HDD's fixing screws do not have a prayer of clearing the chassis. There's actually no clearance for any kind of screw head, and the carrier is not designed for flat head screws.
Image Image Image Image

I thought I was inserting the carrier upside-down, but the SATA connector in the back of the chassis is clearly at the top-right, so I can't flip the drive.

Googling finds no others having this problem, so it's obviously something I've gotten wrong in my head.

The N2200EVO manual just says:
Thecus N2200EVO Manual, page 12 wrote:For 3.5” HDDs
a. Remove an HDD tray and install a 3.5” SATA hard disk onto it.
b. Slide the HDD tray back into the N2200 until it snaps into place.


Scratching my head, missing something obvious.

Posted: Thu May 09, 2013 3:56 pm
by asavage
Image Image Image Image

I don't work on newer computer hardware, and hadn't seen these severely-undercut flathead screws. I don't have any, but apparently that's the answer. 6-32 x 1/4" "F238F"

This is something that's sprung up for affixing computer HDDs in the past decade. Seems to be a Dell thing, and other drive enclosure mfgrs have picked up on it.

What I received from Lewis are 3mm screws that have that undercut head.

Image Image

These screws' OD mic to 0.014"
3mm are 2.98mm or 0.117"
6-32 are 0.138"

Honestly, I have no idea why they would ship 3mm screws. There must be some kind of drive that you'd want to put in this unit that uses them, but it's beyond my ken. Every HDD I've touched over the years has used 6-32 mountings. FDD, DVD/CD -- they use 3mm.

Posted: Mon May 13, 2013 10:19 pm
by asavage
I guess that laptop HDDs (2.5") use 3mm.

I ordered some screws from, a great resource.

However, the screws I ordered, 10303, have too-large countersink heads, drat.

Here's a comparison:
(click on image for larger)


Perhaps this is what I want? Their number 10283:

Posted: Wed May 22, 2013 3:15 pm
by asavage
Temporary-for-testing solution:

Image Image

A couple of rubber bits from the bottom of some long-discarded equipment. Just the right height. I can reliably seat the HDD's SATA connector. Fits nice -- for installation.

It doesn't work at all for removing the HDD -- carrier comes out, HDD stays plugged in :(

Now, where to find time to play with this?

Posted: Thu May 23, 2013 3:14 pm
by asavage
First off: Resetting the N2200EVO

The manual says:
N2200EVO User Manual wrote:In case you changed the N2200 IP address and then forgot it, or forgot the administration password, follow the steps below to reset to default settings:

1. Power on the N2200 and immediately press the Reset button for 5 seconds.
(The reset button is near the LAN connector)

2. This resets the N2200 to its default IP address and password settings.

Default IP:
Default admin password: admin
However, this didn't work for me. I found a more-correct answer: ... 437#p26532
Thecus - Bertha wrote:N2200 has reset button, please follow the step to reset:
1. Shut down NAS
2. Press the reset button then boot NAS, please do not release reset button until you hear beep after 30 secs.
That worked. Hold reset button until it begins to beep. Release button, then wait a further, oh, minute (it's a long time, anyway) until it beeps again, and then it's reset to

Upgrading the firmware

It takes a lot longer than you'd think. Several minutes. After all, the firmware file is around 35Mb !

When rebooting, when it says it takes around 100 seconds to reboot, it's not kidding. I see around 95 seconds.

Next, check the disk. Gotta love those Power On Hours. I worked it out: 391 years!:

Configure the RAID as JBOD for single-disk testing. Notice that the "File System" spinbox is greyed-out, so only XFS is allowed :

Configure Samba, turn on UNIX Extensions:

Then I created a share and a user, and from the eCS box used EVFSGUI to map it to local W: . Results:

[g:\] dir test.png

Volume in drive G is G_FTP Serial number is A5E3:A5BF
Directory of G:\test.png

2-23-13 9:12 920,697 8,169 ___A_ Test.png
[ . . . ]
[g:\] copy test.png w:
G:\Test.png => W:\Test.png
1 file copied

[g:\] dir w:test.png

Volume in drive W is EVFS
Directory of W:\test.png

2-23-13 9:12 920,697 0 ___A_ test.png
[ . . . ]

8,169 of EA data lost in the copy. Sigh.

Posted: Sun May 26, 2013 6:25 pm
by LewisR
Hey, Al...

Some pointers for modifying the smb.conf in the Thecus, from some quick meandering I've accomplished:

Like the Synology, the Thecus stores its configuration in a database and generates the confs at each boot.

With the Synology, it was far more difficult to modify the data in the db than to just script the changes, use sed (or something else) to automate the edits of the as-generated confs, and then restart the service(s), reading the updated configuration.

There is apparently a META module for the Thecus into which you may store the procedure to be run at each restart. Here's a link to get you started with that.

What you need to edit in smb.conf to enable EAs is (likely) to append a single line to the file:

Code: Select all

ea support=yes
and then restart samba.

I think the Thecus will probably be a little more user friendly for this with the assistance of the META module than the time I had with the Synology.


Posted: Sun May 26, 2013 10:31 pm
by asavage
As I mentioned via email, there does not appear to be a META module for the Thecus models that use firmware 1.x, which is what the N2200 has.

The 4100 uses the 2.x firmware, IIRC.

The link you previously sent me via email mentions a version of META that was modified to work with a 5200 (?) and possibly other models. However, the link to that modified version (2.00.2 ?) was a 404 & I was unable to locate a copy anywhere.

Posted: Tue Jun 04, 2013 6:21 pm
by asavage (CS Enterprises, sent me an email, informing me that the correct screws (by their reckoning) is their No. 10249, 6-32 x 1/4 Wafer Head Machine Screw


I ordered a few.

Posted: Thu Jul 04, 2013 2:16 pm
by asavage
The correct screws arrived a few weeks ago, and I got some time just now to try them out. Here's a wrong screw (1st attempt) and a correct screw (2nd attempt) in two different mounting holes, both tightened. The wrong one on the left illustrates why it's a problem. The drive carrier cannot be inserted into the NAS due to the screw head's protrusion.

Image Image Image

Now that I have the correct screws in place, the drive & carrier insert into the NAS fine.

Posted: Fri Feb 07, 2014 12:37 pm
by asavage
Last August, Lewis came up with this elegant solution to enabling extended attributes in the Thecus' Samba server, and I document it here for my own use later:
Lewis Rosenthal wrote:From an ssh session, then, the idea was to add "ea support = yes" to the
smb.conf for every share. To wit:

Code: Select all

N2200EVO:~# sqlite /raid0/sys/smb.db "insert into smb_share (k,v,m) values ('ea support','yes','0')"
Restart samba:

Code: Select all

N2200EVO:~# /img/bin/rc/rc.samba restart


Nothing odd with the Thecus samba implementation or with XFS. However,
when copying the desktop directory of my booted drive from CMD.EXE or
4OS2.EXE, directory EAs didn't get pushed. 4OS2 gave me some bogus
nonsense about extended attributes not being supported on the target
filesystem. DirectoryMaster (PM app) copied them all without a hitch.
JdeBP's 32-bit Command Interpreter seemed to get the \Desktop EAs to
push, but directory EAs under that were not there. In all cases, file
EAs *did* go. I am guessing this is some shortcoming of the eCS SAMBA
client (I have trouble pushing EAs to a NetWare volume using CIFS,
whereas the native NetWare Requester moves them just fine).

Nothing else weird. The drive seems to be have as expected.


. . . this is a "permanent" configuration change. The only time that I can
see you having to re-run the command is if you wipe the configured RAID
volume (such as when you swap out the 40GB drive you sent me with the
unit for a pair of larger ones. once raid0 is recreated, you need to add
that record to the database. A failure of one drive and a subsequent
replacement of it would not be an issue, however.

I just tested this by pulling a spare 80GB drive I had on the shelf and
swapping out your 40GB for that. The unit needed to be reconfigured. I
created a single volume (no RAID, but JBOD). I had to create your test
share again (as expected). After that, I copied a file with EAs to the
share, and they did not go across. I logged in via ssh (ssh -l root, ran the sqlite command and restarted Samba. I then
re-copied the file, and the EAs were there. Finally, I power cycled the
unit. Once it came back up, I ran a dir against the mapped drive:

[results confirmed, list deleted]

Re: Thecus N2200EVO NAS

Posted: Sat Jul 09, 2016 7:23 pm
by asavage
My second Thecus N2200EVO died a month or so back. I picked up a used 2010-vintage N4100Pro from eBay, and am copying the data from one of the old N2000EVO RAID1 drives to the new RAID1 drives in the N4100Pro.

Both models use a web interface for configuration.

Something I've been seeing for a while in both the N2200EVO and now in the N4100Pro is: missing "Enable" and "Disable" buttons' text. It's Firefox. Something changed in Firefox in early Dec2014 that broke the AJAX output's rendering.
In the screenshots below, look to the right of "NTP Service:"

FF 34.0.5 (01Dec2014):


FF 35.0b1 (04Dec2014):


These screenshots were from fresh FF installations, no add-ons, new profile.

Interesting, no? IE8 renders correctly as well.

Firmware tested:
N2200EVO =
N4100Pro = 5.03.02

Thecus N4100Pro NAS notes

Posted: Fri Jul 29, 2016 9:20 pm
by asavage
Notes on Thecus N4100Pro NAS setup: embedded samba server & OS/2 & WinXP Pro

Thecus N4100Pro with (2) HGST 6TB drives in RAID1 (mirrored)

Putty for command line
WinSCP for GUI file manager

Samba (smbd) needs to have its smb.conf modified to add options to allow OS/2 to log in, use shares, and use EAs.
smb.conf is stored in a sqlite database and is regenerated at boot time.
One can either modify the database, or overwrite smb.conf after boot, and restart samba. I did the latter; it was much easier to test changes and roll back what didn't work.

On the N4100Pro, I installed the 3rd-party module META, which allows to run a script at startup. I believe that on the N4100Pro, that may be the only way to autorun a script at startup. The META module that I installed was; although there are references to later versions, this was the only one that I could actually download.

When logging in via Putty or SSH, remember to log in as root -- not a user -- and to use the root's password, which is the same one you use to log in at the web interface. Default is "admin".

The samba version that is installed with Thecus firmware v5.03.02 is 3.5.16

Code: Select all

	root@ ./smbd --version
    Version 3.5.16

Because the N4100Pro runs BusyBox linux, the samba install is stripped-down; there is no pdbedit or testparm, so you have to approach any problems you encounter tangentially.

For configuring OS/2 to use the N4100Pro's samba server, the hurdles I faced included:
  1. Extended Attributes (EAs): The N4100Pro uses XFS, which like HPFS (and HPFS386) can use EAs <=64k ( ... xattr.html), but the EA feature is not enabled.
  2. Protocols: OS/2 needs to use NetBIOS over TCP/IP (port 139) protocol, and must log in to smbd using LanManager v2.1 protocol, plaintext (non-encrypted).
The first is relatively easy: the EA feature of samba is turned OFF by default. This line needs to be added to the [global] section of smb.conf to enable it:

Code: Select all

	ea support = Yes 

The second, though . . .

Samba negotiates the protocol during the first exchange of data. Here's a snippet of the samba log at the beginning of protocol negotiation with an OS/2 computer using the IBM Peer networking via NetBIOS over TCP/IP:

Code: Select all

	Requested protocol [PC NETWORK PROGRAM 1.0]
	Requested protocol [XENIX CORE]
	Requested protocol [LANMAN1.0]
	Requested protocol [LM1.2X002]
	Requested protocol [LANMAN2.1]
	Selected protocol LANMAN2.1

Samba is presenting from lowest to highest security (oldest to newest) the list of protocols it can accept, and both samba & OS/2 settle on LanManager v2.1 .

In order to get samba to even present these (old) protocols, these lines need to be added to the [global] section of smb.conf (as described here: ... -Requester ):

Code: Select all

	lanman auth = true
	client lanman auth = true
	client plaintext auth = true

That will let the process of OS/2 logging to samba begin. However, there's another problem that took me some time to understand: the user/password on the samba side must be created after those lines are added to smb.conf and smbd has been restarted. Why? Samba stores the password in another database, apparently in a way that old LanManager passwords occupy one field, and newer, encrypted passwords in another field. Until those three option lines above are read by smbd and are in force, any user/password you add will not have a LanManager password stored, and all attempts to log in will fail.

If "log level = 3" is set, you can see this failure, with lines similar to this:

Code: Select all

	ntlm_password_check: NO LanMan password set for user arhiv (and no NT password supplied)
	  [2008/09/08 07:06:31, 3] libsmb/ntlm_check.c:ntlm_password_check(457)
	ntlm_password_check: LM password, NT MD4 password in LM field and LMv2 failed for user arhiv
	  [2008/09/08 07:06:31, 2] auth/auth.c:check_ntlm_password(318)
	check_ntlm_password: Authentication for user [ARHIV] -> [ARHIV] FAILED with error NT_STATUS_WRONG_PASSWORD

That was hard to figure out.

For my situation, I'm using WinXP Pro (which networks differently than WinXP Home) with this NAS, as well as OS/2, and WinXP Pro really doesn't like the options needed for LanMan 2.1 to work. The fix for this is to configure samba to use a default that Win likes, and another collection of config values (including those old LanMan 2.1 options) only when the OS/2 computer is logging in. The way to do that is to use samba's variable substitution feature.

In the [global] section of smb.conf, at the end of the section, I added:

Code: Select all

	# Include special config for JONI2 (OS/2, eCS) LanMan
	include = /raid0/sys/smb.conf.%m
This instructs samba to look at the NetBIOS name of every client that attempts to log in, and then look for a file specified. "%m" is the variable substitution for the NetBIOS name. In my case, the OS/2 computer has a NetBIOS name of "JONI2", and when it attempts a login, samba looks for a file named, "smb.conf.joni2" (lower case: samba lowercases all NetBIOS names, and case does matter) and if that file is found, it will load it and process the options within.

smb.conf.joni2 :

Code: Select all

# 16Jul2016 ALS: Added next lines per FAQ
	lanman auth = true
	client lanman auth = true
	client plaintext auth = true

	wide links = Yes
	dos charset = ASCII
	unix charset = UTF-8
	display charset = UTF-8

	# 29Jul2016 ALS: Added below lines.
	encrypt passwords = no
	lm announce = yes
	lm interval = 60 

	# Log level for THIS computer's session (JONI2), & log file location.
	log file = /opt/samba/var/log/samba.%m.log
	log level = 0
	max log size = 100
	debug timestamp = no
Two problems that took longer than usual to understand:
  1. When using smbpasswd to add a user, the change does not appear to be reflected back to the underlying linux system. Deleting a user via smbpasswd does not delete the user seen at the web admin interface.
  2. When using the include directive in smb.conf, smbpasswd will NOT be using those included options when adding/changing a user's password; therefore, it will NOT write the LanMan password to the database. Took me forever to figure that out. Solution: temporarily add those three LanMan lines to the main smb.conf file in the [global] section, restart smbd, use smbpasswd to edit the password (or add the user fresh) that the OS/2 box logs in as, then delete the lines from smb.conf and again restart smbd.

Don't forget turn down the log level to 0 after debugging; log level = 3 will chew up a lot of CPU while writing to log files (though only 200k of disk space as configured above).

When using Notepad++ to save text files, be certain to specify Edit->EOL Conversion->Unix/OSX format. If not, the files will generally not process correctly.

smb.conf.joni2 -> /raid/sys/
Samba_Modify-smb-conf-at-startup.txt -> /raid/data/module/META/system/etc/startup

Logs : /opt/samba/var/logs/
smbd : /opt/samba/sbin
smbpasswd : /opt/samba/bin

Useful command lines for my system:
That file must be set to executable:

Code: Select all

	chmod +x /raid/data/module/META/system/etc/startup/Samba_Modify-smb-conf-at-startup.txt
/opt/samba/bin/smbpasswd -a <username> (make certain that the three LanMan opt lines are active before running this!)
find / -name <filename>
/img/bin/rc/rc.samba restart 1 (handy to restart with new smb.conf after changing something)

Re: Thecus N4100Pro NAS notes

Posted: Mon Aug 08, 2016 6:39 pm
by Nissan_Ranger
Gonna go back to school and learn Greek! :-)

Re: Thecus N2200EVO NAS

Posted: Tue Aug 09, 2016 4:19 am
by asavage
I've been putting off learning/using Linux for years. I don't find this stuff easy.

Linux: Like the Steely Dan song Babylon Sisters says, "Like a Sunday in T.J. [. . .] it's cheap but it's not free". The learning curve is steep.

Re: Thecus N2200EVO NAS

Posted: Sat Apr 01, 2017 2:41 pm
by asavage
Every so often -- measured in months -- the N4100Pro will lose the old LanMan password and while the 'asavage' user is still showing in the NAS' web interface, the OS/2 box cannot log in to it. That means no backups happen. As of today, this has happened twice (in about six months).

The OS/2 box is going to get replaced with an Ubuntu box in 2017, so I'm not going to spend a lot of time trying to figure out why this is happening, but I know I'll have to reset this username/password combo in the N4100Pro a couple more times before we are not dealing with OS/2 anymore, and it's just enough of a PITA to figure out every time it happens that I wrote a script:

Code: Select all

Procedure to reset the user ('asavage') & password for Joni2 (OS/2), which seems to get "lost" in the NAS every so often.
Created: 25Mar2017 ALS
Last update: 16Nov2018 ALS

Delete user 'asavage' using web interface.

ssh to N4100Pro ( as root
    ssh root@
edit /raid/sys/smb.conf:
	Add these lines temporarily, to the end of the [global] section:
         lanman auth = true
         client lanman auth = true
         client plaintext auth = true
  vi notes:	
	vi /raid/sys/smb.conf
	<esc> = command mode
	i = insert mode
	<esc>:wq<enter> = write (save), then quit.
Copy it to tempfs:
    cp -f /raid0/sys/smb.conf /tmpfs/tmp/smb.conf
Restart smbd (do not reboot!):
	/img/bin/rc/rc.samba restart 1
Add user 'asavage' using web interface.
Add user 'asavage' using ssh:
	/opt/samba/bin/smbpasswd -a asavage
Reboot OS/2 box (or restart Lan Requester); it does not seem to "just work" after mods to NAS.
       net stop requester
Test login at JONI2:
    net view \\N4100Pro
Reboot NAS via web interface to allow Win clients to work again.

-- end