NissanDiesel forums

Nissan diesel engines, and the people who love them
It is currently Thu Jul 27, 2017 1:36 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
Post Number:#1  PostPosted: Mon Oct 17, 2016 5:50 am 
Offline

Joined: Mon Jun 06, 2016 12:50 pm
Posts: 8
How's it going, I've posted a couple pictures below of what it's doing. I'm not sure which lights are which, and I'm also not sure what lights are on and what lights are off when either normal lights or highbeams are in use. Regretfully I never payed attention til I had this problem. But anyway the lights are like this almost all the time whether the selector is in highbeam setting or normal beam. Every rare once in a while, while driving, with the selector in normal beam it will switch back on to whatever normal beam is supposed to be but it's too dim to keep it on that, so I switch back to high beam and that's what the pictures show(the selector is on normal beam in the picture). But as you can see the far passenger side light is very dim, the inner side passenger light is lit normal. The inner driver side light is out, and the out driver side light is lit normal. The inner driver side light only had like 2.76v going to it, so I'm not sure if the bulb is out or not getting enough juice to light, either way it should be getting way more volts. The rest have what they are supposed to be getting. And lastly when you move the selector into highbeam the light on the dash doesn't come on ever either. I have no idea what's going on and I hope I have described this situation well enough for someone to give me some answers. I look forward to any replies and hope everyone has a good day! Thanks in advance for answers


Attachments:
20161017_065901.jpg
20161017_065901.jpg [ 3.39 MiB | Viewed 806 times ]
20161017_065852.jpg
20161017_065852.jpg [ 4.02 MiB | Viewed 806 times ]
20161017_065843.jpg
20161017_065843.jpg [ 5 MiB | Viewed 806 times ]
Top
 Profile  
Reply with quote  
Post Number:#2  PostPosted: Mon Oct 17, 2016 6:55 am 
Offline

Joined: Fri Aug 31, 2007 6:49 am
Posts: 792
Location: Cochrane Alberta Canada
My guess is bad switch and/or perhaps poor body ground.

You can try and purchase or source a new switch or remove the one you have and see if you can clean it out with some contact cleaner and compressed air. Although I do not have a Maxima I do have a Nissan truck from that era and have had a number of problems with different switches on it. The 4 way flasher switch and the turn signal switch. I removed them and soaked every little nook and cranny that may give entry to the inside where all the contacts live with contact cleaner and given them a good blow out with an air hose. It seems to have solved the problem. I have also checked and cleaned off with a wire brush or sand paper all the body grounds that I could find.
Dim lights and weird electrical problems most times are caused by bad grounds.
Not exactly sure where on a Maxima the main body ground is but that would be where I start. You can test it with a jumper cable from the Neg side of the battery to that point or to the wire connected to it.

Good luck and keep us posted.

_________________
Retired Pauly
Problem with being retired is that you never get a day off.
1987 D21-J SD25 KC
KJLGD21FN


Top
 Profile  
Reply with quote  
Post Number:#3  PostPosted: Tue Oct 18, 2016 5:41 am 
Offline

Joined: Mon Jun 06, 2016 12:50 pm
Posts: 8
Are the pictures I posted viewable? I made the post on my phone and I don't know if they didn't post correctly or if my phone is being stupid and won't load them


Top
 Profile  
Reply with quote  
Post Number:#4  PostPosted: Tue Oct 18, 2016 6:15 am 
Offline

Joined: Fri Aug 31, 2007 6:49 am
Posts: 792
Location: Cochrane Alberta Canada
Yes they are.
They take a few seconds to load and are oriented 90 degrees but they are there and show what you are talking about.

I still think it's a bad ground someplace.
I'm sure others will chime in.

_________________
Retired Pauly
Problem with being retired is that you never get a day off.
1987 D21-J SD25 KC
KJLGD21FN


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group