Turbo 4x4 build version 2.0

This is where we can post about our rigs, specs, ongoing plans, etc., links to pics.

Moderators: goglio704, Nissan_Ranger

bacho
Posts: 121
Joined: 13 years ago
Location: Greenville South Carolina

#16

Post by bacho » 12 years ago

Another update again. I have the truck in my possension again to it can get a solid axle in the front. Heres the latest,

Truck has been running 15psi boost - it was doing 8 when I gave it to him, he made no adjustments (doesnt know how)
Its been running 1,200 continious on the pyro - told him 1,200 was the red line when i sold it.


We are seeing some problems though. Its alot harder for me to diagnose these issues since I am not drive it all the time but here it goes. The truck is smoking very badly most of the time. Its a white smoke, just like it used to on a very cold morning. However its smoking badly still after it warms up. The crazy thing is that some times it doesnt smoke at all, for instance he drove it over here and there was zero smoke anywhere. He shut it down and started it 10 minutes later and the smoke is back. Any ideas?

The truck has also had a very hard time starting cold without the use of Ether. I havent tried it yet, but he cant start it without some ether the first time its started in the morning. I think hes been running it pretty hard, and the motor is getting worn out.

Its auctually pretty fast running this much boost, but I am gonna turn the fuel down to get him back down to 10 or so and see if I can force the pyro down some more. I am not sure if it will make any difference anymore though.
1992 nissan pathfinder 4x4
1985 KC 720 4x4
1982 KC 720

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest