I Need a Lift Pump!!

Dealing with all subsystems specific to the diesel powered Datsun-Nissan 720 pickup trucks.

Moderators: plenzen, Nissan_Ranger

Post Reply
confederatear
Posts: 2
Joined: 5 years ago

I Need a Lift Pump!!

#1

Post by confederatear » 5 years ago

I have a 1981 720 and I'm almost 100% sure my lift pump is bad. Does anyone know where i can find a new one. Any input would be greatly appreciated.

waynosworld
Posts: 517
Joined: 7 years ago
Location: Vancouver Washington USA

Re: I Need a Lift Pump!!

#2

Post by waynosworld » 5 years ago

I am going to ask you if your positive it's the lift pump, I know you said 100 percent, but I have only heard of one bad lift pump ever, and it was damaged because the person pulling it apart didn't know what they were doing.
Have you checked/changed all your filters?
A plugged pre-filter will make you truck act like it is running out of gas.
Have you checked your banjo fitting?
Where are you located?
I know the voices are not real,
but they have some really good ideas.

scottfelsen
Posts: 5
Joined: 5 years ago

Re: I Need a Lift Pump!!

#3

Post by scottfelsen » 5 years ago

I bought a diesel fuel ump from Orileys Auto Parts that was compatible with diesel fuel and pumped between 5 and 10 psi. Installed it right near the gas tank and I keep a spare in the truck because these tend to break every few years. There are cheaper ones you can buy but its so important I went with one costing about 100 bucks. Without this pump my truck will not run. I have seen them break many times.
Just ask for a fuel pump that pumps 5 to ten psi. It doesn't need to be specific for your truck. It just needs to get fuel to the mechanical fuel pump on the side of your engine. It also needs to work with diesel fuel.

confederatear
Posts: 2
Joined: 5 years ago

Re: I Need a Lift Pump!!

#4

Post by confederatear » 5 years ago

Im in South Carolina. Im not sure whats going on with it. I found a banjo fitting lose and tighten it and the problem stopped for a few weeks so i replace the filter with an acdelco. a few days after that the problem started back up. I have clear lines coming from the lift pump to the filter and there is air coming from it. I have Bypassed the frame rail line and the problem is no different. I have also Replaced the line coming from the hard line to the lift pump along with a new primer. I absoluty love the truck and really need to figure it out.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests