Samsung front-load washing machine, code "nd" fix

Ongoing discussion of anything not related to Nissans or diesels.

Moderators: goglio704, Nissan_Ranger, kassim503

Post Reply
User avatar
asavage
Site Admin
Posts: 5329
Joined: 14 years ago
Location: Duvall, Wash.
Contact:

Samsung front-load washing machine, code "nd" fix

#1

Post by asavage » 1 year ago

[21Feb2018 ALS: Copied from my review of the replacement water level sensor I purchased at Amazon. I'm re-posting the review here so I can include the link to the technical manual.]

Samsung front-load washing machines have issues. Lots of them, and there seem to be dozens of variations of their front-loaders, so fixes for one model don't work for another.

We bought our washer/dryer pair in Spring 2010 from Sears. The drain pump on the washer's been noisy since at least 2012, but it's always worked, so [shrug].

The WF219ANB/XAA front-loader started giving the dreaded (and common) "nd" code (no drain) last week. While I had the usual issues with junk in the lower filter and a partially obstructed drain hose (the installer had a loop in it!), cleaning it all out didn't fix it: the tub would drain two or three times OK, then another "nd". If you search for that code and Samsung, everybody will point you to a failed water pump, clogged discharge hose, clogged pump inlet hose, etc.: all problems related to getting the water out of the tub. The water pump motor is cheap (the pump + motor a bit less so) but the labor is not so easy, due to having to remove the top and front of the machine to access the pump enough for removal (you can just barely reach and remove the hoses, but that's about as far as you'll go). So, I wanted to make damned certain that the pump had to be replaced.

The technical manual (with diagnostic instructions) is part number DC68-02443B-02. It, or its equivalent, is crucial to doing thorough diagnosis. Thank Samsung that mine was taped to the rear of my washer, because it is not readily available online, AFAICT.

Technical Manual DC68-02443B-02

Putting the machine in Quick Test mode and manually filling the tub (QT mode lets you use the front panel buttons to operate functions manually, so you can for example way overfill the tub manually) then turning on the pump and watching the discharge hose into a 5-gallon bucket showed that it was discharging water just fine. Actually, quite a bit better than I'd have guessed for a dinky 3/4" hose on an electric pump the size of half a loaf of bread. So, the problem was not the common one of pump/motor failure or hose restriction.

The Board Input Test of the water level sensor signal (output is shown on the LED panel!) was showing a water level sensor frequency of 284 (28.4khz) for full and 624 (62.4khz) for empty.

Not knowing the normal specs, I rolled the dice and purchased this ERP ERDC96-01703B replacement for the original DC96-01703B (that's the right part No., according to Samsung's website). While the metal bracket of the original does not come with this replacement, apparently neither does the metal bracket come with the genuine Samsung part. However, electrically it appears to work OK. I now have a full tub reading of 438, an empty tub reading of 632, and have run two loads to completion without an "nd" code; previously, I could not get through a heavy-duty cycle without it stopping.

It's early days, and who knows how durable this $14 replacement will be, but out-of-the-box it seems to have solved my no-drain problem.

[09Mar2018]
Fifteen loads later, no problems. I'm calling the "nd" (no drain) problem solved, by replacing the water level sensor.

Following several guides on YouTube, etc., I have also adjusted the water level via the plastic screw-top on this sensor, to provide about one minute more water run time during fill cycles. The water level is noticeably higher. Make small (1/2 turn) adjustments and check. I ended up at two turns in for about one add'l minute of fill time at 70 PSI inlet pressure.

Fixed my problem, though the EPR part is not a drop-in, screw-compatible replacement.
Attachments
Samsung_DC96-01703B_Water_Level_Sensor_01b.jpg
Top of washer off.
Samsung_DC96-01703B_Water_Level_Sensor_01b.jpg (1.65 MiB) Viewed 684 times
Samsung_DC96-01703B_Water_Level_Sensor_02b.jpg
Original 2009-vintage water level sensor (affixed with integrated metal bracket).
Samsung_DC96-01703B_Water_Level_Sensor_02b.jpg (1.66 MiB) Viewed 684 times
Samsung_DC96-01703B_Water_Level_Sensor_03b.jpg
Replacement sensor loosely connected.
Samsung_DC96-01703B_Water_Level_Sensor_03b.jpg (2.07 MiB) Viewed 684 times
Samsung_DC96-01703B_Water_Level_Sensor_04b.jpg
Replacement sensor zip-tied to chassis.
Samsung_DC96-01703B_Water_Level_Sensor_04b.jpg (1.87 MiB) Viewed 684 times
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest