Dell T7500 Precision

Ongoing discussion of anything not related to Nissans or diesels.

Moderators: goglio704, Nissan_Ranger, kassim503

Post Reply
User avatar
asavage
Site Admin
Posts: 5329
Joined: 14 years ago
Location: Duvall, Wash.
Contact:

Dell T7500 Precision

#1

Post by asavage » 3 years ago

Seems like a good-enough place to post notes on a pair of Dell T500 Precision tower workstations I've picked up recently. They are large and quiet and not cheap.

The first box ("Winni3") will be my personal workstation replacement and will host several virtualized OSs (XP, W7, maybe W4). Specs today:
2x Xeon X5690 3.46Ghz, hex core
48Gb RAM (soon to be 96Gb, I think)
2x 1T SSD Samsung 80 on LSI PCIe HBA, RAID 1 (mirrored)
1100W power supply
1.5GB Nvidia Quadro FX4800 video card -- I don't need high-end vid, I rarely do more than Photoshop.

Ubuntu 15.something and VMWare Workstation Pro 12 on this one. Sitting idle, it was locking up every one to three days. Lots of Googling found a few things to try, notably:
The latter appears to work for me.

The second box will be a NAS server to augment or replace the Thecus N2200EVO, which works but tends to need rebooting more often than I'd like. I have to get down to the post office today and pick it up.

I've bought a pair of used Dell 30" 3008WFPT monitors. Heavy and eight seconds to turn on, but 2560x1600 and lots & lots of inputs. I needed 27"+ and higher res than 1920x1280.

http://www.ebay.com/itm/371480047393 -- jump on one while you can. It's listed as 2560x1024 which is incorrect -- I'm running both of mine at 2560x1600. I assume that's why this seller still has some available at his price point.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.

User avatar
asavage
Site Admin
Posts: 5329
Joined: 14 years ago
Location: Duvall, Wash.
Contact:

Dell T7500 Precision

#2

Post by asavage » 3 years ago

I just upgraded "Winni3" from 48Gb to 128Gb RAM. Half the RAM sits on the mainboard, the other half on the 2nd CPU riser card. The 2nd CPU riser card must be removed to add/change RAM at either location.

After installing the new RAM, it wouldn't boot. The power button was solid amber (not blinking) and the front panel diagnostic lights 2-3-4 were blinking, with all the fans eventually ramping up to pretty high speeds. Removing the 2nd CPU riser card allowed normal boot.

Google found this problem, and G-Man49 fixed his by supporting the 2nd CPU with shims. Yup, that seems to work here too. Make sure the LED on the mainboard at the upper left goes out before rebooting, as even with a fixed/supported riser, if that light doesn't go out between reboot attempts the same symptom seems to persist.

(Note that it's very easy to install RAM incorrectly on this model, as three DIMMs are required per CPU as a minimum, and they must be installed in slots 1, 2, 3 but those numbers aren't contiguous on the boards!)

You can't just stack quarters or washers or whatever as I have done below for illustrative purposes, because the side cover fits on that ledge. I went with a jackscrew.
Attachments
T7500_CPU_Riser_Support_02b.jpg
T7500_CPU_Riser_Support_02b.jpg (1.66 MiB) Viewed 1487 times
T7500_CPU_Riser_Support_01b.jpg
T7500_CPU_Riser_Support_01b.jpg (2.49 MiB) Viewed 1487 times
T7500_CPU_Riser_Support_03b.jpg
T7500_CPU_Riser_Support_03b.jpg (1.99 MiB) Viewed 1487 times
T7500_CPU_Riser_Support_04b.jpg
T7500_CPU_Riser_Support_04b.jpg (2.5 MiB) Viewed 1487 times
T7500_CPU_Riser_Support_05b.jpg
T7500_CPU_Riser_Support_05b.jpg (1.63 MiB) Viewed 1487 times
T7500_CPU_Riser_Support_06b.jpg
T7500_CPU_Riser_Support_06b.jpg (871.54 KiB) Viewed 1487 times
T7500_CPU_Riser_Support_07b.jpg
T7500_CPU_Riser_Support_07b.jpg (893.01 KiB) Viewed 1487 times
T7500_CPU_Riser_Support_08b.jpg
T7500_CPU_Riser_Support_08b.jpg (1.83 MiB) Viewed 1487 times
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.

User avatar
asavage
Site Admin
Posts: 5329
Joined: 14 years ago
Location: Duvall, Wash.
Contact:

LSI SAS 9207-4i4e heat sink

#3

Post by asavage » 3 years ago

The T7500's SATA ports are limited to 3Gb/s (SATA II). It seems that most PCI & PCIe SATA III adapter cards (HBA) do not really support high enough bandwidth to fully utilize a SATA III's 6Gb/s spec., especially modern SSDs or even merely multiple fast spinning disks that have a 6Gb/s interface.

One way around that is to use a better HBA. I settled on an LSI SAS 9207-4i4e. Seems to work great so far, but it has a MPU that gets so hot that I cannot keep my finger on it, even when the box is idling. The spec calls for 200 lfm of airflow, and perhaps my box (that has eight fans) doesn't meet that. My fix is more heatsink and a dedicated fan.

Here's what it looks like from the factory:
4812_02_lsi_evolves_to_pci_express_3_0_new_products_announced_full.png
4812_02_lsi_evolves_to_pci_express_3_0_new_products_announced_full.png (311.48 KiB) Viewed 1847 times
That black heatsink is not very tall, and not very large. It's held to the PCB via metal posts with split barbs, and springs provide the clamping force:
LSI_SAS_9207-4i4e_02b.jpg
LSI_SAS_9207-4i4e_02b.jpg (854.77 KiB) Viewed 1847 times
LSI_SAS_9207-4i4e_09b.jpg
LSI_SAS_9207-4i4e_09b.jpg (492.9 KiB) Viewed 1847 times
LSI_SAS_9207-4i4e_11b.jpg
LSI_SAS_9207-4i4e_11b.jpg (400.36 KiB) Viewed 1847 times

I bought a $14 CPU heatsink/fan combo for an AMD Socket A (462), a Masscool 5R057B3 60mm:
LSI_SAS_9207-4i4e_07b.jpg
LSI_SAS_9207-4i4e_07b.jpg (803.27 KiB) Viewed 1847 times
LSI_SAS_9207-4i4e_08b.jpg
LSI_SAS_9207-4i4e_08b.jpg (878.56 KiB) Viewed 1847 times

I unscrewed the fan and here's the square inches comparison:
LSI_SAS_9207-4i4e_05b.jpg
LSI_SAS_9207-4i4e_05b.jpg (1.3 MiB) Viewed 1847 times
LSI_SAS_9207-4i4e_06b.jpg
LSI_SAS_9207-4i4e_06b.jpg (1.05 MiB) Viewed 1847 times

Next, I drilled the copper heatsink for the post barbs, then used a Dremel to cut back the fins. I did it wrong the first time, transferring the holes from the old heatsink to new backward, that's why there are four holes instead of two. The Dremeling was fussy work, taking a lot longer than you'd think. Then I trial-fit it:
LSI_SAS_9207-4i4e_12b.jpg
LSI_SAS_9207-4i4e_12b.jpg (1.23 MiB) Viewed 1847 times
LSI_SAS_9207-4i4e_16b.jpg
LSI_SAS_9207-4i4e_16b.jpg (1.63 MiB) Viewed 1847 times
I needed to remove the old thermal transfer paste, and it was really nasty to remove. No luck with denatured alcohol, it wouldn't touch it. Aerosol carb cleaner was only slightly better. Acetone did the job, but it still took more work than I'd thought it would:
LSI_SAS_9207-4i4e_13b.jpg
LSI_SAS_9207-4i4e_13b.jpg (501.79 KiB) Viewed 1847 times
LSI_SAS_9207-4i4e_14b.jpg
LSI_SAS_9207-4i4e_14b.jpg (357.17 KiB) Viewed 1847 times
LSI_SAS_9207-4i4e_15b.jpg
LSI_SAS_9207-4i4e_15b.jpg (1.56 MiB) Viewed 1847 times

Screwed the thin ball bearing fan back to the heatsink:
LSI_SAS_9207-4i4e_17b.jpg
LSI_SAS_9207-4i4e_17b.jpg (1.34 MiB) Viewed 1847 times
LSI_SAS_9207-4i4e_18b.jpg
LSI_SAS_9207-4i4e_18b.jpg (804.11 KiB) Viewed 1847 times

Installed, the fan & heatsink now completely obscure the adjacent PCI slot, but that's no loss: what's PCI anymore?
LSI_SAS_9207-4i4e_19b.jpg
LSI_SAS_9207-4i4e_19b.jpg (2.43 MiB) Viewed 1847 times
I had also bought a $9 fan speed controller, Gelid FC-FX01, because this MPU will not need a fraction of the cooling of an AMD CPU, and I don't need the noise of a 4800 RPM fan.
LSI_SAS_9207-4i4e_21b.jpg
LSI_SAS_9207-4i4e_21b.jpg (1.36 MiB) Viewed 1847 times
LSI_SAS_9207-4i4e_20b.jpg
LSI_SAS_9207-4i4e_20b.jpg (2.03 MiB) Viewed 1847 times
The last piece I needed was a Molex 4-pin to fan 3-pin adapter to provide power to this controller. I happened to have one laying around in a drawer.

With the fan controller turned all the way toward minimum, the fan noise cannot be distinguished from all the other fans running in there, and the copper heat sink is 105°F in a 72°F ambient room. Much better.

[20Jan2018: the internal breakout cable I used is 3WARE Cable Multi-lane Internal Cable (SFF-8087), to adapt from the LSI's single internal port to four SATA drives.]
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest