Log in issue

News & discussion about the forum's server, hardware, software, upgrades, features, etc.

Moderator: Nissan_Ranger

Post Reply
TheDieseliminator
Posts: 205
Joined: 14 years ago
Location: Florence, AZ
Contact:

Log in issue

#1

Post by TheDieseliminator » 14 years ago

Al, for about the past week every time I visit the site it doesn't recognize me as being online under my username. I have the website under my favorites and every time I visit now at the top of the page I see "Log In" everytime. Used to be that everytime I visited I would see my username at the top of the page, but instead now I'm only being identified as a guest. Do you know what the problem could be?

Salvy

Guest

#2

Post by Guest » 14 years ago

The session times out after about an hour, I think. No activity within an hour = logout. This was changed when I loaded the "login redirection mod" in early Dec, but that mod gave everyone fits -- including me -- so I didn't re-add that mod when I updated the base forum software after Christmas.

Can you use the "log me in automatically" checkbox at the bottom of the main page? I've never tried it -- I use Mozilla, which fills in the username & password automatically, all I have to remember is to click on the "log in" button.

I will put it on my list to see if I can find in the php code where the session timeout is. I may be able to stretch it a bit, but unless you have it log you in automatically (using a cookie), that's probably the best I can do. You're welcome to look over the php code yourself, if you're a php expert. I know enough to do simple projects, but I don't code for a living anymore.

I'm leaving for a couple of days, so I won't be able to read your reply until Sunday, probably.

User avatar
asavage
Site Admin
Posts: 5346
Joined: 14 years ago
Location: Duvall, Wash.
Contact:

#3

Post by asavage » 14 years ago

And I forget to log in a lot. Which isn't a problem, until I end up posting as "Guest". Oh, well.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.

TheDieseliminator
Posts: 205
Joined: 14 years ago
Location: Florence, AZ
Contact:

#4

Post by TheDieseliminator » 14 years ago

Al, actually I do always check "the log me in automatically" box everytime I visit the site. But it still doesn't matter, the next time I visit it still doesn't remember me. I can understand that the session times out after an hour and I have absolutely no experience with php code. Thanks for the help though.

User avatar
asavage
Site Admin
Posts: 5346
Joined: 14 years ago
Location: Duvall, Wash.
Contact:

#5

Post by asavage » 14 years ago

TheDieseliminator wrote:Al, actually I do always check "the log me in automatically" box everytime I visit the site. But it still doesn't matter, the next time I visit it still doesn't remember me.
Confirmed. I set up my office box to use the "log in auto" and it doesn't. I'll put that on my to-do list, thanks.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.

User avatar
asavage
Site Admin
Posts: 5346
Joined: 14 years ago
Location: Duvall, Wash.
Contact:

#6

Post by asavage » 14 years ago

I screwed up the cookie settings with the phpbb upgrade over Christmas/New Years -- it was the default domain change that did it, plus the root change to a different dir. I think I've straightened it out -- "login automatically" works here now at the office. Try logging out and logging in, check the box for "login automatically", then after logged in, close the browser, open it back up and go to the site -- you should be logged in. WFM. Let me know.

I've also bumped the session timeout from one hour to two hours. Anybody want more than that? I really hate it when I've started a post, walk away, come back and finish it, then on Submit it wants to log on again. Blech.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.

TheDieseliminator
Posts: 205
Joined: 14 years ago
Location: Florence, AZ
Contact:

#7

Post by TheDieseliminator » 14 years ago

Al, I just visited the site about 30 minutes ago and signed in, looked around, read some posts, etc. Decided to click on it in my favorites and I'm posting here to tell you it's a success. The site loaded and showed I'm logged in at the top of the page. I think you have fixed the issue. You've done all you can in my opinion and it has fixed my problem. Thanks a lot man.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest