Smoke at Idle, Not under Load...

SD diesels were widely available in the US in the 1981-86 Datsun/Nissan 720 pickups, and in Canada through '87 in the D21 pickup.

Moderators: plenzen, Nissan_Ranger

Post Reply
4x4 SD22
Posts: 1
Joined: 7 years ago
Location: Klamath Falls Oregon

Smoke at Idle, Not under Load...

#1

Post by 4x4 SD22 »

Hi guys, I'm a long time fan first time user.
So I've been into these SD diesels for a bit now and I've done a few transplants and stuff. So far all has gone well, except for my newest edition; 85 Nissan truck standard cab.
Soon after I completed the transplant I started driving it and as usual it smoked for the first little bit (first 25 miles or so), but after it warmed up no problems. I ran it good and hard put about 100 miles on it. It still smokes! but only at idle not under load, and its an un-burnt fuel smoke. I know the engine is good, the doner truck ran great with only 160k (it had a bad trans, bad body, ext).
I did some investigating and at idle the problems always comes back, it misses in cylinder 1&4. I'm thinking its due to Air in the Lines cuz I can crack them while its running and it blows bubbles for a second. The system has been bleed and bleed, all the lines are new, it's always hard to start (I've never used starting fluid).
I'm fairly capable, and this is not my first diesel by far, but I'm baffled by this one... :?
waynosworld
Posts: 525
Joined: 8 years ago
Location: Vancouver Washington USA

#2

Post by waynosworld »

Have you checked your valve clearances?
Does it have an inline injection pump, or is a VE type?
I know the voices are not real,
but they have some really good ideas.
User avatar
asavage
Site Admin
Posts: 5370
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

#3

Post by asavage »

If you suspect air in the lines, use the temporary clear vinyl fuel supply line method to ascertain whether it's sucking air.

If it does this when hot, you can rule out the usual culprit: problems with the glow plug system, which give cold miss and white smoke, a very common SD22 problem.

Checking the valve clearances isn't a bad idea in general, but they really shouldn't be changing much, and esp. not closing down. You may want to perform a compression test to rule out cylinder imbalance.

I think your guess about air getting to the IP is a good one.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
big0078
Posts: 5
Joined: 14 years ago
Location: MID-MISSOURI

#4

Post by big0078 »

try a new leather in the injector
pump
BIG-O
User avatar
asavage
Site Admin
Posts: 5370
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

#5

Post by asavage »

If it's got an Inline IP, and the leather governor diaphragm is leaking, you'll get black smoke at idle, not white.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
larrynsr
Posts: 25
Joined: 10 years ago
Location: portland oregon

#6

Post by larrynsr »

check that the throttle body hoses are not kinked going to the injection pump. too much fuel not enough air causes black smoke.
81' Volvo 240 Wagon
SD25/Turbo/Intercooler/Propane
Post Reply

Who is online

Users browsing this forum: Google [Bot] and 4 guests