Epson GT-15000 large-format scanner

Ongoing discussion of anything not related to Nissans or diesels.

Moderators: goglio704, Nissan_Ranger, kassim503

Post Reply
User avatar
Site Admin
Posts: 5359
Joined: 15 years ago
Location: Duvall, Wash.

Epson GT-15000 large-format scanner


Post by asavage »

My old Mustek Paragon 1200 A3 Pro (11"x17") scanners have died of old age. I've scanned probably thousands of pages on the first one, only a hundred or so on the second. I got the first one free from a business that didn't like the four-minute fluorescent lamp warm-up time, and it was a real workhorse for me. The combination of age and SCSI finally prompted me to buy a replacement.

I chose a 2003-era Epson GT-15000 ($393 shipped) (substantially the same as the GT-20000), which has both SCSI and USB interfaces built-in, and I found a rare (or, merely expensive: $129 shipped) optional ethernet adapter, EU-81 (aka B12B808393 or B808393), so it can be easily shared amongst all our networked computers here.
Epson GT-15000 large-format flatbed scanner
Epson GT-15000 large-format flatbed scanner
Epson_GT-15000_01b.jpg (36.53 KiB) Viewed 296 times
EU-81 Network Adapter (Ethernet)
EU-81 Network Adapter (Ethernet)
Epson_Network_Adapter_EU-81_01b.jpg (26.94 KiB) Viewed 296 times
EU-81 Network Adapter (Ethernet)
EU-81 Network Adapter (Ethernet)
Epson_Network_Adapter_EU-81_02b.png (41.07 KiB) Viewed 296 times
EU-81 Network Adapter (Ethernet)
EU-81 Network Adapter (Ethernet)
Epson_Network_Adapter_EU-81_03b.png (103.58 KiB) Viewed 296 times
EU-81 Network Adapter (Ethernet)
EU-81 Network Adapter (Ethernet)
Epson_Network_Adapter_EU-81_04b.png (33.65 KiB) Viewed 296 times

SANE explicitly supports the GT-15000, but only the SCSI & USB ports, using the epson2 backend. However, I had a strong suspicion that the ethernet adapter could also be used, which turned out to be true. One advantage of buying older computer equipment is that the pioneers have already fought the major, common issues and documented them.

I am using this scanner primarily with Ubuntu (now at 18.04).

One pleasant surprise was that the EU-81 adapter was already configured to use DHCP, and when powered-on its built-in configuration webserver let me view the current settings and firmware level. I only had to use my router's "who's connected" page to figure out the GT-15000's DHCP IP via the MAC on the EU-81.

Unfortunately, I didn't know the password for the EU-81. While its webserver will happily show me settings without credentials, it won't let me change them. So, I had to push the Reset to Factory Defaults button on the EU-81 (hold the Reset button, power on unit, hold button for a further ten seconds then release). That's where the real trouble began.

Epson's Factory Defaults for the EU-81:
EU-81 Factory Defaults table
EU-81 Factory Defaults table
EU-81_Factory_Defaults_01b.png (59.39 KiB) Viewed 855 times isn't exactly an easy subnet to access.

arp worked to "reset"* the IP:

Code: Select all

arp -s <ip address> <media access control (MAC) address>
In my case:

Code: Select all

arp -s 00:00:48:CD:80:0A (use colons for Linux, hyphens for Win environments)
The MAC is printed inside the EU-81 (but I'd already copied it from the router's "who's connected" screen).

*(arp -- the Address Resolution Protocol -- doesn't really reset the IP; it updates the computer's internal table of IP<->MAC addresses so an IP address, which is 32-bits, can be used to address (talk to) the device via it's 48-bit MAC address on a LAN. IOW, arp changes the computer, not the scanner's NIC.

Now I could again access the EU-81's internal webserver, and theoretically and set my own password (and change settings). In practice, the default username isn't documented and the web UI won't allow password change without username. I was able to use EpsonNet Config 4.9.5 to reset password (leaving username blank); see next paragraph.

Next, I proved the network connection via the Epson-supplied scanning utilities for Windows. In my case, I keep a WinXP virtual machine setup running via VMWare Workstation Pro, very handy for this kind of thing. I installed Epson Scan 3.04a and EpsonNet Config 4.9.5; the latter is more or less the same functionality as the webserver has. Those are in the bundle epson12178.exe (20mb); older versions are floating around. After install, Epson Scan was able to scan across the LAN, proving the hardware was working and configured.

Then the SANE/Ubuntu part was . . . a less clear path.

When you Google "SANE network scanner", you're invariably pointed to installations where a scanner is connected to a remote computer (via USB, SCSI, FireWire, or parallel port), and a SANE daemon (saned) runs on that remote box, making that scanner available to a SANE client running on your computer.

However, that's not how a network-attached scanner works, and it can be hard to tease out the steps to make that work.

SANE itself installs on Ubuntu without fuss. But, in its default configuration, it won't see the GT-15000, because . . . the Epson GT-15000 with EU-81 doesn't use the epson or epson2 backends, it uses the epkowa backend, which in turn requires Epson/Avasys iScan + iScan Network Plugin.

[edit 23Jul2020 ALS: much removed here because Epson iScan (Image Scan for Linux) is now readily available and has been updated]

As of this writing, Epson Image Scan ("iScan") v3.63.0 is available here:, and un-tar'ing it and running ./ worked well.

Then, edit /etc/sane.d/epkowa.conf (config file for epkowa backend) and insert the GT-15000's IP address. Add:

Code: Select all

net [IP address] [port]
to the file. In my case:

Code: Select all

The default port is 1865 and I didn't need to specify it; it's optional.

Now, all these work:
  • Epson Scan (on WinXP, in a virtual machine)
  • XSane
  • simple-scan
  • scanimage -L
For a data point, sudo sane-find-scanner does not find any network scanners; it's designed to find scanners that are attached to the local computer via USB, SCSI, and a few parallel port scanners only.

[Update 22Jul2020]

I've added an Epson GT-2500 Plus to my home network. The GT-2500 is in the same family of Epson scanners as the large-format GT-15000 above. The GT-15000 has an optional ADF; the GT-2500 comes with an ADF standard. The Plus variant of the GT-2500 comes with the same Network Image Express Card (NIC) as outlined above; the standard, non-Plus GT-2500 has a slot for the NIC but doesn't ship with it.

I actually bought three GT-2500/Plus units: two without ADF input paper trays but with the Plus NICs, and one without a NIC but with the tray.

The GT-2500s (either Plus, or with the NIC installed) set up exactly the same way as the GT-15000 above did.
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests