Injection pump and general info

Discuss (and cuss) the Nissan LD-series OHC Six diesel engine, popularly available in the US in 1981-83 Datsun/Nissan Maxima Sedans & Wagons.

Moderators: plenzen, glenlloyd, goglio704, Nissan_Ranger

Post Reply
shark
Posts: 14
Joined: 14 years ago
Location: Port Orange, Fl

Injection pump and general info

#1

Post by shark »

Hello,
This is a great forum! I have just purchased my first Nissan/Datsun diesel an 83' maxima. The car seems to run well but has to crank for five too ten seconds before starting. The injection pump is leaking a lot. I can not see the actual leak but it flows down around the sides at the rear of the pump. I have seen the variuos posts about the problem and will keep reading. Please let me know what posts to focus on and/or provide additional info if available.

I plan to use biodiesel. Where can I find the seals for the IP that make it more suitable for biodiesel use? Posts or other info for install would be appreciated.

Outside of the engine compartment the front seats are trashed. Been looking at the junk yard for some replacements. Does anyone know what other years or model seats would be direct replacements. The junk yards seem to be full of mid 80's Pulsars.

Not a mechanic by trade but I do like to tinker until the problem is licked. Just do not want to screw something up in the process. Thanks for whatever help you can offer.
1983 Maxima diesel
2002 VW Bug TDI canary yellow (Wife's car)
User avatar
asavage
Site Admin
Posts: 5359
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

Re: Injection pump and general info

#2

Post by asavage »

Hello, Shark, and Welcome to our Sandbox!

Please take a minute and update your Profile, at least the geographic info. Select "Profile" from the top of any page.
shark wrote:I have just purchased my first Nissan/Datsun diesel an 83' maxima.
Sedan or Wagon? 5-spd or AT?
The car seems to run well but has to crank for five too ten seconds before starting.
That's quite a long time. Shudders and smokes when it finally starts? You will want to look hard at the fusible links and the big spade terminal connector below the battery (two wires, both White or White/Black). You may not be getting enough voltage to the GP bus. Connectors are a problem on this 20+ yr old car.
The injection pump is leaking a lot. I can not see the actual leak but it flows down around the sides at the rear of the pump.

I plan to use biodiesel. Where can I find the seals for the IP that make it more suitable for biodiesel use?
This thread has viton IP seal info, including where to buy it. However, I wouldn't expect fuel leakage from the front seal to exhibit on the sides and rear. You may have a top cover leak, or an accel shaft leak (both of which are common on the VW version of this Bosch VE IP).

You will need to replace all the fuel lines if you are going to run B100. B20 or weaker will probably not require fuel line replacement.
Outside of the engine compartment the front seats are trashed. Been looking at the junk yard for some replacements. Does anyone know what other years or model seats would be direct replacements. The junk yards seem to be full of mid 80's Pulsars.
Member 83_maxima is running '87 Maxima seats in his '83. See this post for details.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
shark
Posts: 14
Joined: 14 years ago
Location: Port Orange, Fl

#3

Post by shark »

Thanks for the quick response.

"Sedan or Wagon? 5-spd or AT?"
Automatic, sedan, blue failing repaint job but no rust. Post some pix later.

"Shudders and smokes when it finally starts?"
The car seems to run fine once started no smoke and cranks well until it fires. Tought this might have something to do with the leak.

I just ordered a manual from the Advanced Auto store. One of those crappy Hayes ones. asavage, Did I see in another thread that you have shop manuals available?

One other question. A silver box on the back of the right side shock tower heats up very quick and gets very HOT. This box has two wires going to it and I do not know what it is without a manual. Danger of fire here or is it supposed to get hot?
1983 Maxima diesel
2002 VW Bug TDI canary yellow (Wife's car)
User avatar
kassim503
Posts: 1027
Joined: 15 years ago
Location: Stony Brook, NY

#4

Post by kassim503 »

shark wrote: One other question. A silver box on the back of the right side shock tower heats up very quick and gets very HOT. This box has two wires going to it and I do not know what it is without a manual. Danger of fire here or is it supposed to get hot?
Uh oh!

I wouldnt run it until you get that fixed, Nothing on the passenger side shock tower gets hot. Then again I have a gas model and not a diesel. Still shoudlnt get hot though, is it luke warm? Hot enough to burn skin? Glowing? (jkjk)


Ummmmm I have a rusted box on the shock tower with 2 wires and thats for the air conditiong if im correct, ill look into the FSM tommorow or something. I woudlnt drive it until that gets resolved.
'83 maxima sedan, l24e, a/t, black

227K SOLD 6/7/2012
shark
Posts: 14
Joined: 14 years ago
Location: Port Orange, Fl

#5

Post by shark »

A trip around the block but not driving until I get the fuel leak fixed. The box gets hot enough to burn skin "just ask my palm". I will await a response on the nature of this part or confirmation in thje manual before starting the car or trying to disconect the box.
1983 Maxima diesel
2002 VW Bug TDI canary yellow (Wife's car)
User avatar
kassim503
Posts: 1027
Joined: 15 years ago
Location: Stony Brook, NY

#6

Post by kassim503 »

Because I love 1st gen maximas so much, I went thru the FSM for a breif overview of the engine compartment. I bet I can find more, but its late and im not digging into it right now.

If the box looks like the A/C relay sketched below I think thats your problem. Ill also run my accesories tommorow and see if they get warm (shouldnt but you never know).

Click on the link below for the full size pic, the detail should be good enough for you to read

If you want outstanding quality, click on it the picture another time once it loaded, itll be really nice and very readable

Image (dead image link)

The page was from the 83 maxima FSM with both the gas and diesel info in it. Pg EL-162
'83 maxima sedan, l24e, a/t, black

227K SOLD 6/7/2012
shark
Posts: 14
Joined: 14 years ago
Location: Port Orange, Fl

#7

Post by shark »

The box in this picture, silver on back of the shock tower is the one getting hot. I just did a test and it gets hot when you turn the key into the run position when the car dings and the glow plug light illuminates. Keeps getting hotter as the key is left in position.

Picture would not attach I can email it.
1983 Maxima diesel
2002 VW Bug TDI canary yellow (Wife's car)
User avatar
asavage
Site Admin
Posts: 5359
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

#8

Post by asavage »

Kassim, you really shouldn't dabble in things you don't know, unless you want your hand chopped off :twisted:
shark wrote:"Sedan or Wagon? 5-spd or AT?"
Automatic, sedan, blue failing repaint job but no rust. Post some pix later.
When you do, do it in the User's Rigs forum.
"Shudders and smokes when it finally starts?"
The car seems to run fine once started no smoke and cranks well until it fires. Tought this might have something to do with the leak.
OK. If it comes up on all six, doesn't shudder and doesn't belch white smoke right after starting, it's probably not a GP system issue.

Next would be to check for proper voltage at the IP shutoff solenoid wire.
Image
If you've got low voltage there, the IP may not be "turning on" right away. Just a shot in the dark. You might be correct, it could be a fuel leakage thing, but I'd expect air in the high pressure lines to give erratic running if that were the case.
asavage, Did I see in another thread that you have shop manuals available?
I buy them surplus at eBay when nobody else bids on them. I have lots & lots of 1982 & 1983 Maxima FSMs right now. I could put one in the mail for $20, shipped, no problem.

However, this one on eBay just failed to get any bids, ended yesterday, you could probably contact the seller and buy it for $14 shipped. I didn't bid on it because I already have several and that was too much for me to spend for another one, and I can't sell you one of mine for less because I pay dual shipping (one inbound, one outbound). Anyway, either way you should definitely get a FSM, you can't work very long on one of these without one.
A silver box on the back of the right side shock tower heats up very quick and gets very HOT. This box has two wires going to it . . .
It's the afterglow dropping resistor, and it gets hot after the main GP relay drops out (the noisy one). So it will be cold when you start glowing, and after you hear the loud "CLACK", it will heat up fast in afterglow mode. Hot is normal.

Though it's from the '82 FSM, this GP schematic diagram is the same as in 1983. It even shows the box location.
Last edited by asavage 11 years ago, edited 1 time in total.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
User avatar
asavage
Site Admin
Posts: 5359
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

#9

Post by asavage »

shark wrote:The box in this picture, silver on back of the shock tower is the one getting hot. I just did a test and it gets hot when you turn the key into the run position when the car dings and the glow plug light illuminates. Keeps getting hotter as the key is left in position.
Aha! You may have just diagnosed your problem.

The GP system has two relays. They both get engaged at the same time when the engine coolant is under 122°F and you turn the key to ON. Relay 1 is the main relay (next to the silver box, inboard and above it slightly), has a White/Black wire and a White wire for input/output, and a Light Green wire for trigger. That's the loud relay.

Because the main relay is wired direct (sorta) to the GP bus, but relay 2 is wired through the dropping resistor, normally nearly no current flows through relay 2 at first. When relay 1 opens up (loudly), relay 2 is now carrying all the current to the GPs -- at a reduced voltage, due to the dropping resistor.

If the main GP relay doesn't work (relay failed, bad connector, whatever), relay 2 is the only current source for the GPs, and they won't heat up fast enough to make starting easy. Do voltage checks at all three terminals of relay 1.
Picture would not attach . . .
This forum software (phpBB) does not natively support attached files. I have spent most of the day deciding whether to do a MOD (that will allow attaching files to posts) or going directly to v3b2 of the software. Looks like the former. But you folks will have nowhere to go while I'm doing it, and it'll take a while -- last time, it took most of a weekend. So I'm waiting for the weather to get worse.

File attachments are coming. Meanwhile, use other photohosting services.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
User avatar
asavage
Site Admin
Posts: 5359
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

#10

Post by asavage »

Also look at this thread for more seat info.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
User avatar
asavage
Site Admin
Posts: 5359
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

#11

Post by asavage »

Also, look at the GP Wiring Diagram (as opposed to the Schematic link I posted upthread). Look at connector 9M, which is the fusible link for the GP system. Also connector 44M-10E which is a GP harness connector at the GP bus that is also troublesome.

Image Image
(The second pic is one I took yesterday for an upcoming "Simplify/modify the GP wiring" post I intend to do)
Last edited by asavage 14 years ago, edited 1 time in total.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
shark
Posts: 14
Joined: 14 years ago
Location: Port Orange, Fl

#12

Post by shark »

Thanks again for the great info. I just took the battery out and where the negative attaches to the battery tray had a lot of corrosion. I cut that part out and will splice together. Will test relay #1 when the battery is again hooked up

Back to the injection pump. Can the seals that normally go bad be replaced without removing the pump? Just looking at the area in question brings the thought of messing something up more real each moment.(first diesel I have worked on) I don't want to just start taking things apart unless that is what it takes. Took the battery and washer bottle out for more room to work. Until I can find a manual any info on removing pump or replacing seals would be great.
1983 Maxima diesel
2002 VW Bug TDI canary yellow (Wife's car)
User avatar
asavage
Site Admin
Posts: 5359
Joined: 15 years ago
Location: Duvall, Wash.
Contact:

#13

Post by asavage »

shark wrote:Back to the injection pump. Can the seals that normally go bad be replaced without removing the pump?
Yes. Member goglio704 did it a few months back. It's the front shaft seal.

You will want to review the FAQ, IP Belt section. Replacing the IP belt is routine maintenance (60k), and getting to the IP shaft seal is not much more work, once you're there.
Regards,
Al S.

1982 Maxima diesel wagon, 2nd & 4th owner, 165k miles, rusty & burgundy/grey. Purchased 1996, SOLD 16Feb10
1983 Maxima diesel wagon, 199k miles, rusty, light yellow/light brown. SOLD 14Jul07
1981 720 SD22 (scrapped 04Sep07)
1983 Sentra CD17, 255k, bought 06Jul08, gave it away 22Jun10.
shark
Posts: 14
Joined: 14 years ago
Location: Port Orange, Fl

#14

Post by shark »

Hard start seems to be fixed by a new battery cable and waiting about an extra five seconds after the glow plug light goes out, then starting. I did hear the loud main relay pop off just after starting. Guess it works. :D

Another problem noticed is a hard shutter as the car is turned off. Not like a run on, just a quick shutter as the engine stops. Any ideas?

Thanks for all the help. I hope with some experience to start contributing instead of just taking advise.
1983 Maxima diesel
2002 VW Bug TDI canary yellow (Wife's car)
User avatar
kassim503
Posts: 1027
Joined: 15 years ago
Location: Stony Brook, NY

#15

Post by kassim503 »

asavage wrote:Kassim, you really shouldn't dabble in things you don't know, unless you want your hand chopped off :twisted:
Lol!
'83 maxima sedan, l24e, a/t, black

227K SOLD 6/7/2012
Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest